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1 Introduction 

CADS Revit Scia Engineer link facilitates the bi-directional exchange of members, loads and supports 
between Revit Structure and Scia Engineer and in doing so plays a vital role in the overall Building 
Information Modelling (BIM) process. A structure modelled in Revit Structure can be transferred to 
Scia Engineer for structural analysis and design using CADS Revit Scia Engineer link. When the 
structural analysis and design has been completed in Scia Engineer, the updated model can be sent 
back to Revit Structure. The modelling - analysis - design process requires numerous iterations to 
arrive at the final design. CADS Revit Scia Engineer link will save time by avoiding duplication and 
reducing errors.  
 
This Getting Started guide will help you with instructions on how to install the software and make 
the best use of CADS Revit Scia Engineer link to manage your BIM process successfully. 
 

The Content libraries in Revit are stored as a collection of the Revit family (*.RFA) files. Please ensure 
that the country specific libraries are installed on the system while installing Revit. 

 

 
Figure 1-1: Revit installation option 
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2 Compatibility 

CADS Revit Scia Engineer link is shipped with a Release Notes document which lists the versions of 
Revit Structure and Scia Engineer with which it is compatible. You can also find this document in the 
following folder: 
 
C:\Program Files\Revit To Scia Engineer\RevitStr20xx\Docs 
 
C:\Program Files folder is the default installation folder for CADS Revit Scia Engineer Link.  
 

 
Figure 2-1: CADS Revit Scia Engineer Link installation folder 

 
RevitStr20xx is the Revit Structure version number on which CADS Revit Scia Engineer link is 
installed. 
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3 Workflow 

CADS Revit Scia Engineer link supports the following workflows:  

3.1 Revit Architecture to Scia Engineer round trip 

 
 
 
 

 
 
 
 
 

 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 

 
Figure 3-1: Revit Architecture to Scia Engineer round trip 
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3.2 Revit Structure to Scia Engineer round trip 

 
Figure 3-2: Revit Structure to Scia Engineer round trip 

3.3 Scia Engineer to Revit Structure round trip 

 
Figure 3-3: Scia Engineer to Revit Structure round trip  
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4 Installation 

This section sets out how to install CADS Revit Scia Engineer link on various system environments. 
 

If you wish to have a direct link between Revit Structure and Scia Engineer, you should have 
both applications installed and licensed on your system. 
 
If only one of the applications is licensed (i.e. Revit Structure or Scia Engineer) and you wish to share 
your model with your colleague then you need to use the file based transfer method. This means, 
you will have to create a *.R2S file from either of the applications and then import it into the other 
application.  
 
ESA RevitLink (ESA.21) module should be licensed as part of the Scia Engineer installation to 
exchange models in between Revit Structure and Scia Engineer. 
 

 
Figure 4-1: Scia Engineer - Protection setup dialog 

4.1 Revit Structure and Scia Engineer licensed on the system 

1. Check in the Release Notes whether the Revit Structure version is compatible with the 
version of CADS Revit Scia Engineer link you wish to install on your system. If yes, then 
continue with the installation, or else install the required version of either Revit Structure or 
Scia Engineer 

2. Run CADS Revit Scia Engineer link installation and select the options as prompted in the 
dialogs 

3. Finish the installation. 
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4.2 Only Revit Structure licensed on your system 

1. Check in the Release Notes whether the Revit Structure version is compatible with the 
version of CADS Revit Scia Engineer link you wish to install on your system. If yes, then 
continue with the installation or else install the required version of Revit Structure. 

2. Run CADS Revit Scia Engineer link installation and select the options as prompted in the 
dialogs. 

3. CADS Revit Scia Engineer link requires that Scia Engineer is installed on the system to 
generate the *.R2S file. A licensed copy of Scia Engineer is not mandatory, for example, just 
the installation of a Scia Engineer demo version should be sufficient. 

4.3 Only Scia Engineer licensed on your system 

CADS Revit Scia Engineer link installation is not required. As long as you have the ESA RevitLink 
(ESA.21) module installed and licensed on your system you can export or import the *.R2S file from 
Scia Engineer as explained in Section 5. 

4.4 Neither Revit Structure nor Scia Engineer license 
present on your system 

CADS Revit Scia Engineer link requires at least one of the above applications to be installed and 
licensed on the system for it to work. 
 

 CADS Revit Scia Engineer link can be also installed on Revit Architecture or Revit MEP, but this 
is not advisable as the correct structural model may not get transferred to/from Scia Engineer. A 
structural model in Revit should have an analytical line associated with all structural elements. The 
analytical properties of a structural element can be modified from the Revit Properties tab. 
 

 
Figure 4-2: Analytical lines in Revit Structure  
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5 Basic commands 

In order to transfer the model from Revit Structure to Scia Engineer, you must specify the following: 

5.1 Version of Scia Engineer 

You will have to select the Scia Engineer version you wish to use for export/import of models. 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Options -> General -> Scia Engineer 
Version -> Browse -> Add 

 

 
Figure 5-1: CADS Revit Scia Engineer Link - Options button  

 
Figure 5-2: CADS Revit Scia Engineer Link - Add Scia Engineer version dialog  

Click on the Add button to select the Scia Engineer root folder as shown below: 
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Figure 5-3: CADS Revit to Scia Engineer Link - Browse for Scia Engineer folder  

 
Select OK and then Close the previous dialog. 

5.2 Code of practice 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Options -> National Code 
 

 
Figure 5-4: CADS Revit Scia Engineer Link - Options button  
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Figure 5-5: CADS Revit Scia Engineer Link - National Code  

 

Select the National Design Code you wish to use in Scia Engineer before exporting the mode from 
Revit Structure. CADS Revit Scia Engineer Link will automatically select the appropriate Scia 
Engineer template to create the model. 
 
The first time you import a project from Scia Engineer into Revit Structure, ensure that you create a 
new Revit Structure file and select the correct template file as per the country code used for 
creating the job in Scia Engineer. 
 

Revit Structure -> New -> Project 
 

 
Figure 5-6: Revit Structure - New project dialog  

 
Use the Browse button to locate the correct template file.  
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Figure 5-7: Revit Structure - Choose template dialog  

You may choose any customised Revit Structure template file as well, but make sure that the 
units are the same as those used in the Scia Engineer model. For example, if the Scia Engineer model 
is created in Metric units, then the Revit Structure template should also be in Metric. 
 
Ensure that the Revit Structure libraries of structural members are available in the default Revit 
Structure installation folder, for example the library of UK cross sections are available in the 
following folder for Revit 2017 by default. 
 
C:\ProgramData\Autodesk\RST 2017\Libraries\UK 

 
Figure 5-8: Revit Structure - Cross section library folder  

If you are using the library of customised Revit Structure families and/or the library of Revit 
Structure families stored in LAN, you have to configure the folder location where these Revit 
Structure families are stored. 
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You can access this from: 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Options -> Preferred tables -> Revit 
Family Path 
 

 
Figure 5-9: CADS Revit Scia Engineer Link - Options button  

 
 

 
Figure 5-10: CADS Revit Scia Engineer Link - Revit family path  
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5.3 Model export / import 

There are two ways in which a model can be exchanged between Revit Structure and Scia Engineer: 

 Direct exchange method: In this method the model is transferred directly between Revit 
Structure and Scia Engineer without the need of any data exchange file. You must have both 
Revit Structure and Scia Engineer licensed on your system to use this method of model 
exchange.  
 

 R2S file exchange method: If you have either Revit Structure or Scia Engineer licensed on 
your system then you can exchange modes using a data exchange file in the *.R2S format. 

 
Should you wish to transfer a model using the Direct exchange method, you should set the option 
Launch Scia Engineer to Yes.  
 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Options -> Preferences -> Launch Scia 
Engineer 

 

 
Figure 5-11: CADS Revit Scia Engineer Link - Options button  

 

 
Figure 5-12: CADS Revit Scia Engineer Link - Launch Scia Engineer  

 
The matrix below shows how the CADS Revit Scia Engineer Link works when you use the export or 
import feature from Revit Structure or Scia Engineer. 
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 Revit Structure Scia Engineer 

Export Import Export Import 

Launch 
Scia 
Engineer 
= Yes 

Invokes Scia Engineer 
automatically with the 
same file name and folder 
location as that of a Revit 
Structure job. 

Imports the Scia 
Engineer job into Revit 
Structure # 

Prompts you to 
specify the file name 
for the *.R2S file you 
wish to create which 
can be imported into 
Revit Structure. 

Prompts you to 
select the *.R2S file 
you created / 
modified from Revit 
Structure. 

Launch 
Scia 
Engineer 
= No 

Prompts you to specify the 
file name for the *.R2S file 
you wish to create which 
can be imported into Scia 
Engineer. 

Prompts you to select 
the *.R2S file you 
created/modified in Scia 
Engineer. 

 

Figure 5-13: Model export & import matrix  

 
#Owing to certain programming API limitations, while importing the job into Revit Structure you 
might get an error message ‘Unable to find Scia Engineer model’. In such cases, please follow the 
following steps: 

 
1. Save the job in Scia Engineer 

2. Close Scia Engineer 

3. Open Revit Structure 

4. Create a new job  

5. Save the new job with a dummy Revit Structure file name, e.g. Test.rvt 

6. Export the job to Scia Engineer with Launch Scia Engineer = Yes 

7. A new session of Scia Engineer will be created. Open the original job (point 1) in this session of 

Scia Engineer 

8. Now import the Scia Engineer job into Revit Structure 

5.3.1 Case 1: Export from Revit Structure to Scia Engineer 

Revit Structure -> CADS -> Scia Engineer Link -> Export 
 

 
Figure 5-14: CADS Revit Scia Engineer Link - Export model from Revit Structure to Scia Engineer  
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You can export the structural model in Revit Structure to Scia Engineer using the Review & Export / 
Export option.  
 
Using the Review & Export will open the review manager that will list the changes to export by 
comparing the current Revit model with the last exported model. If this is a first time export, it will 
list all the items as ‘New’ under the ‘Changes’ column as shown below. 
 

 
Figure 5-15: CADS Revit Scia Engineer Link – Review & Export – Model Preview  

 
The review manager lists the element ID, member category, cross section, material, type of change 
and an option to export. The preview on the left zooms to show the selected ID.  
 
The following changes to structural members and openings are tracked by the review manager in 
this release: 

 New  - when a new item is available in the current model; 

 Cross section – changes to the cross section (for example UB 305x102x25 to UB 305x127x37 

or wall thickness changed from 200 mm to 300 mm); 

 Dimension – changes to length of 1D members such as beam, column and changes to 

dimensions of 2D elements such as slab; 

 Position - if the structural element is moved from its previous position, including changes in 

eccentricity; 

 Rotation – changes to cross section rotation; 

 Material – changes to material; 

 Member releases – changes to member end releases such as hinges in Scia Engineer; 
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 Opening – changes to opening dimension, position; 

 Delete – when a member is deleted in Scia Engineer. 

Changes to Loads and Supports are not tracked by the review manager in this release. 
Elements deleted from the Revit model will not be listed as the review manager compares just the 
currently available items. 
 
You can save the contents of the review manager into a file by clicking on the Save log for future 
reference. Clicking on the Export To option in the preview allows you to save the file to multiple file 
formats. 
 

 
Figure 5-16: CADS Revit Scia Engineer Link – Review & Export – Save Log  

 
Using the selection in the last column (Export) you can choose not to export a particular element by 
un-ticking it. Clicking on Export will automatically perform Revit’s Analytical Consistency Check.  
 
It displays the following dialog if any errors / warnings exist providing an opportunity to correct the 
errors thus ensuring the Revit model is good for structural analysis prior to export. 
 

 
Figure 5-17: CADS Revit Scia Engineer Link – Review & Export – Export – Analytical Consistency Check  
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Please save the Revit model once the export is completed in order to enable the review manager to 
track the changes.  
 
Alternatively you may choose the Export option which directly starts to create the Scia Engineer 
model (without tracking). 
 

 
Figure 5-18: CADS Revit Scia Engineer Link – Export  

 
CADS Revit Scia Engineer Link will open an instance of Scia Engineer and create a Scia Engineer 
model with the same file name as that of Revit Structure. You may either choose to create a new 
Scia Engineer file or overwrite an existing one by setting the following option. 
 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Options -> Export to Scia Engineer -> 
Create New 

 

 
Figure 5-19:  CADS Revit Scia Engineer Link - Options button 

 

 
Figure 5-20: CADS Revit Scia Engineer Link - Create new Scia Engineer file  
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When the option Create New is un-ticked, only the changes in the model will be updated to the 
existing Scia Engineer file. Where the model is being transferred for the first time then CADS Revit 
Scia Engineer Link will automatically create a new Scia Engineer file (*.ESA) with the model. 
 
If the option Create New is ticked, CADS Revit Scia Engineer Link will overwrite the entire model 
information in the Scia Engineer file. If an existing Scia Engineer file with the same name is available 
then the old data in the file will be completely replaced by the new model data.  
 

 If you already have a Scia Engineer session open in your system then CADS Revit Scia Engineer 
Link may open another session owing to certain programming limitations.   
 
For the R2S file exchange method of model exchange, the *.R2S file generated from Revit Structure 
can be imported into Scia Engineer using the Import or Update option. 

Scia Engineer -> File -> Import -> Revit File 
 

 
Figure 5-21: Scia Engineer - Import Revit file  

 
The Import option will create a new Scia Engineer file and add the model information to it. 
 

Scia Engineer -> File -> Update -> Revit File 
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Figure 5-22: Scia Engineer - Update Revit file  

 
The Update option will update only the changes to an existing Scia Engineer file. 

5.3.2 Case 2: Import from Scia Engineer to Revit Structure 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Import 
 

 
Figure 5-23: CADS Revit Scia Engineer Link - Import model from Scia Engineer to Revit Structure  

 
You can import a Scia Engineer model into Revit Structure using the Review & Import / Import 
option.  
 
Click on Review & Import to track the changes between the Scia Engineer model and the current 
Revit model. 
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Figure 5-24: CADS Revit Scia Engineer Link – Review & Import – Model Preview  

 
You can choose not to import a change by using the option in the last column. This is particularly 
helpful if the changes are specific to analysis.  
 
During import, CADS Revit Scia Engineer Link will always update the existing mode available in Revit 
Structure. 
 
First set the standard Code of Practice and ensure the cross section library is mapped correctly 
before starting the import as detailed in Section 5.2 Code of practice. 
 
You may import the model into Revit Structure from Scia Engineer using the *.R2S file too. 
 
 In both cases, you can use the Select Changes option to highlight the new or updated elements. 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Select Imported 
 

 
Figure 5-25: CADS Revit Scia Engineer Link - Select changes  

 
For the R2S file exchange method, you will have to first create a *.R2S file from Scia Engineer using 
the following option: 
 

Scia Engineer -> File -> Export -> Revit File 
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Figure 5-26: Scia Engineer - Export Revit file  
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6 Features 

Structural elements present in Revit Structure or Scia Engineer can be exchanged between the two 
applications, provided both the products support them. For example, you can apply a Moment in 
node in Scia Engineer but there is no equivalent feature in Revit Structure, hence it will be ignored 
when you import a model into Revit Structure from Scia Engineer. 
 
Similarly, structural properties may be known by different names, but are mapped based on their 
role. For example, the ‘line support’, known as Boundary Condition – Line in Revit Structure is 
equivalent to Support - Line on Beam or Support – Line on 2D Member in Scia Engineer. 
 
A complete list of features supported is available in the Help file. 
 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Help -> Introduction -> Bi Directional 
Link between Revit and Scia Engineer 
 

 
Figure 6-1: CADS Revit Scia Engineer Link - Help button  

 
All structural elements present in a Revit Structure project will be exported to Scia Engineer if the 
configuration option Export Selected Items Only is un-ticked. This includes all the members physically 
present in the Revit Structure project irrespective of whether the Worksets they lie in are active or 
not. 
 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Options -> Export Selected Items Only 
 

 
Figure 6-2: CADS Revit Scia Engineer Link - Options button  
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Figure 6-3: CADS Revit Scia Engineer Link - Export selected items only  

 
It is possible to specify the format of the node names to be used in the Scia Engineer model through 
the Node format option. It is used only for export from Revit to Scia Engineer for the first time. 
 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Options -> Node Format 
 

 
Figure 6-4: CADS Revit Scia Engineer Link – Options – Node Format  
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Structural members visible in the Revit Structure job but linked to external Revit or other CAD files 
will not be exported, for example linking an external Revit Structure file using the Insert->Revit Link 
option. 
 
You may choose to export only the selected members by ticking the configuration item Export 
Selected Items Only. This option could be very useful when you have a very large job but would like 
to analyse the structure in parts or would like to send updates for only a few members. 
 
There is no such option available when you export the job from Scia Engineer. All structural 
elements present in Scia Engineer will get imported into Revit Structure. 

6.1 Log of events 

Whenever you export or import a model from Revit Structure, a log of important events is created. 
For example: 
 
"UC356x368x202" is mapped as "UC356/368/202" 

 Doors | Doors 4      - 225505 : Not exported as this is not a structural element! 

 
- Where 225505 is the member ID in Revit Structure 

 
The log will list the different categories of items present in the model and their status. 
 

 
Figure 6-5: CADS Revit Scia Engineer Link – Save Log file  

 
It is recommended to save the log as a *.RTF file using the Save Log button for checking and version 
control purposes. 
 
Items which are successfully exported or imported are marked in blue. Elements that could not be 
exported/imported or have some issues attached to it are marked in red. You can highlight the 
affected member in Revit Structure by using Manage->Select by ID option in Revit Structure. 
 
In the absence of a review manager, this is a very good option to highlight the elements marked in 
red in the log file and then take appropriate corrective action to export/import the member again.  
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Figure 6-6: CADS Revit Scia Engineer Link – Error checking in log file 

 
For example in the above log file, a warning that the analytical line is not in the proper position is 
given for floor slab 227544. You can use the Manage->Select by ID option in Revit Structure to 
highlight the slab and take the required action. 
 

 
Figure 6-7: Revit Structure - Select by ID 

 

 
Figure 6-8: Revit Structure - Select elements by ID  

 
You may then change the required member attributes and send only the selected elements using the 
option Export Selected Items Only. 
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6.2 Member export/import 

The standard cross section and material libraries in both Revit Structure and Scia Engineer are 
comprehensive but are labelled differently. For example BS – Universal Beam (UB) sections are 
named as UB254/102/25 in Scia Engineer but as UB254x102x25 in Revit Structure. 
 
Therefore, CADS Revit Scia Engineer link is shipped with a pre-installed mapping library which 
matches cross sections and material properties between Scia Engineer and Revit Structure. In 
addition to the above, you can also specify your own mapping rules for any new section you add to 
the library. 

 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Options -> User Table 
 

 
Figure 6-9: CADS Revit Scia Engineer Link - Options button 

 
Figure 6-10: CADS Revit Scia Engineer Link - User tables  
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Figure 6-11: CADS Revit Scia Engineer Link - Mapping tables  

 
The Database drop down menu contains the different section libraries that the CADS Revit Scia 
Engineer Link supports. For each library you will find data mapped between Revit Structure and Scia 
Engineer cross sections and materials using the Table drop down menu. 
 
You cannot edit any pre-installed mapping database, but you can add new mapping rules by 
selecting the User Table in the Database dropdown menu. 

 

 
Figure 6-12: CADS Revit Scia Engineer Link - User table  

 
Click on the Add button to include your customised Revit Structure family (*.RFA) file to the cross 
section Database. You can add cross sections or material to the User Table only. Please contact CADS 
Support if you wish to update the pre-installed mapping database.  
  
You can map the Revit Structure family (*.RFA) file with the sections available in the Scia Engineer 
cross section library. The cross section library can be selected from the Supporting Mapping 
Database drop down menu. 
 
The example below shows how you can add your custom Revit Structure family (*.RFA) file to the 
User table.  
 

mailto:support@cads.co.uk?subject=CADS%20Revit%20Scia%20Engineer%20Link%20-%20Member%20mapping%20rule
mailto:support@cads.co.uk?subject=CADS%20Revit%20Scia%20Engineer%20Link%20-%20Member%20mapping%20rule
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Figure 6-13: CADS Revit Scia Engineer Link - Add cross section to the user table  

 

 
Figure 6-14: CADS Revit Scia Engineer Link - Revit family file  

 



Revit Scia Engineer Link Getting Started 

 
 
   

 
28    Copyright © 2016 Computer and Design Services Limited 

 
Figure 6-15: CADS Revit Scia Engineer Link - Mapping tables  

 
The feature is useful when you edit some details of the existing family or create a new one.  
 
Please refer to the Help file ->Bi Directional Link between Revit and Scia Engineer on how members 
are mapped between Revit Structure and Scia Engineer. 
 

 
Figure 6-16: CADS Revit Scia Engineer Link - Help file  

 
Where CADS Revit Scia Engineer link encounters a cross section or material that is not available in 
any of its libraries, it will ask you to map the cross section while the export or import command is in 
progress. Once you map the cross section or material, it gets added to the User Table. This mapping 
can be used the next time the same cross section or material is found. Thus as you keep working 
with CADS Revit Scia Engineer link, your user table will keep growing, adding the cross sections and 
the materials you generally work with. 
 
Where a duplicate entry is found for the same cross section or material type then you will be 
prompted to select the appropriate one during the export or import process.  
 

Whilst exporting or importing a project, you might unexpectedly be required to map a member or a 
material. If you are not sure, just use your best guess and then once the export or import is over; you 
can review the log file, highlight the member, change the cross section and export/import the 
member again. 
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6.3 Rotation 

The Member cross section definition in Scia Engineer differs from that of Revit Structure. CADS 
Revit Scia Engineer Link maps the sections between these two different applications. Revit 
Structure depends on the Revit family (*.RFA) to define the cross section properties. Revit family is a 
very powerful tool but is also prone to errors since a cross section can be defined in many different 
ways. The default section library does not follow a systematic pattern to define a cross section. 
Hence CADS Revit Scia Engineer Link depends on mapping files to map the sections.  
 
CADS Revit Scia Engineer Link has developed the mapping logic based on the default cross section 
library supplied with Revit Structure. Since the Revit family implementation logic is not uniform in 
Revit Structure you might find that the log file shows a message such as Member rotated. This is 
done to ensure that the cross section’s handing (plane about which a cross section is mirrored) and 
orientation (member rotation about its centroid) with respect to the model are maintained in both 
Revit Structure and Scia Engineer.  
 

This is generally not a problem with symmetrical sections, but with asymmetrical sections you might 
find that some sections are transferred with a different handing or orientation. In these cases please 
check if the Revit family used for member mapping is a custom made Revit Family or a default one 
supplied with Revit Structure. For a custom made Revit family try changing the variables which 
affect member handing and orientation and use those values which gives the correct result. Please 
get in touch with the CADS Support team if there is any issue with the cross sections library supplied 
with Revit Structure. 

6.4 Eccentricity 

CADS Revit Scia Engineer Link ensures that the member eccentricity is correctly updated during the 
model exchange between Revit Structure & Scia Engineer. Since the parameters required defining 
eccentricity is different in Revit structure and Scia Engineer, you may find the eccentricity 
parameters showing slightly different values, but the relative position of the member with respect to 
the centre line is maintained. 

6.5 Support 

Foundations and Boundary conditions can be exported from Revit Structure to Scia Engineer either 
as a foundation block or as supports. These can be specified from the configuration option Export 
Revit Foundation. If it is set to Support then the foundations are exported to Scia Engineer as Fixed 
Supports, otherwise the foundations are exported as Foundation Blocks in Scia Engineer. 

 Revit Structure -> CADS -> Revit Scia Engineer Link -> Options 
 

 
Figure 6-17: CADS Revit Scia Engineer Link - Options button  

mailto:support@cads.co.uk?subject=CADS%20Revit%20Scia%20Engineer%20Link%20-%20Member%20mapping%20rule


Revit Scia Engineer Link Getting Started 

 
 
   

 
30    Copyright © 2016 Computer and Design Services Limited 

 

 
Figure 6-18: CADS Revit Scia Engineer Link - Export Revit isolated foundation as option  

 
If you have placed any Boundary Conditions (Point, Line or Area) in Revit Structure then it will get 
exported as supports in Scia Engineer with the same translational and rotational stiffness values as 
specified in Revit Structure. When a job is imported into Revit Structure from Scia Engineer for the 
first time the supports are ignored and they do not get imported as Revit Structure Foundataions or 
Boundary Conditions since CADS Revit Scia Engineer Link has no information about its structural 
usage. But if the model is first created in Revit Structure using the Boundary Conditions feature then 
when you edit the support condition in Scia Engineer and import it back into Revit Structure, it 
recognises that the supports were mapped to Boundary Conditions and will update it with the 
modified values. 
 
Where the support parameters are modified in Scia Engineer and you do not wish them to get 
overwritten during the next export from Revit Structure, set the configuration option Ignore Support 
to Yes. 
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Figure 6-19: CADS Revit Scia Engineer Link - Ignore support 

 

 Supports can be exported from Revit Structure to Scia Engineer only when Structural Settings 
in Revit Structure is set to include Member Supports as shown below. 
 

 
Figure 6-20: Revit Structure - Structural settings  



Revit Scia Engineer Link Getting Started 

 
 
   

 
32    Copyright © 2016 Computer and Design Services Limited 

 
Figure 6-21: Revit Structure - Member supports  

6.6 Loads 

Loads modelled in Revit Structure can be exported to Scia Engineer and you can import them back 
into Revit Structure after modifying them in Scia Engineer. You may also choose to model loads in 
Scia Engineer and import it into Revit Structure.  
 
The self-weight of the structural member is not exported to Scia Engineer from Revit Structure. You 
may change the load values if required in Scia Engineer using Scia Engineer’s standard product 
features.  
 
Please refer to the features list in the Help file to check how the load types are mapped between the 
two applications. 
 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Help -> Introduction -> Bi Directional 
Link between Revit and Scia Engineer 

Figure 6-22: CADS Revit Scia Engineer Link - Help button  
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Bi-Directional exchange of load cases and load combinations are also supported by CADS Revit Scia 
Engineer link.  Structural Engineers may choose to ignore load cases and load combinations specified 
in Revit Structure and handle them in Scia Engineer separately. You can opt to ignore load cases and 
load combinations in Revit Structure by setting the configuration option Ignore Revit Load 
Combination to Yes. 
 

Revit Structure -> CADS -> Revit Scia Engineer Link -> Options -> Filters -> Ignore Load 
Combinations 
 

 
Figure 6-23: CADS Revit Scia Engineer Link - Options button 

 

 
Figure 6-24: CADS Revit Scia Engineer Link - Ignore load combinations option  


