SCIA Engineer OpenAPI
19.0.1219
|
This class is used for definition of result you want to get. More...
Public Member Functions | |
ResultKey () | |
Constructor for definition of new result key More... | |
string | TextOutput () |
Method that provide text output of result key. It can be used to print the text representation of key into command line. More... | |
Properties | |
eDimension | Dimension [get, set] |
This enum defines the dimension of obtained results: eDim_undefined = -1, eDim_1D = 1, //FB_1D //results on beams eDim_2D = 2, //FB_2D //2D macros eDim_3D = 3, //FB_3D //3D macros eDim_reactionsPoint = 4, //FB_REA_PT, // reactions in points eDim_reactionsLine = 5, //FB_REA_LIN, // reactions on lines eDim_2DSection = 6, //Results on 2d sections eDim_1DSection = 7, //Results on 1d sections eDim_Storey = 8 //Results per storeys More... | |
string | EntityName [get, set] |
Name of the entity/member (SEn name) for which you want to get results More... | |
eDsElementType | EntityType [get, set] |
This enum defines the type of entity for which you results will be obtained: eDsElementType_None, eDsElementType_Beam, eDsElementType_Slab, eDsElementType_Storey, eDsElementType_Node, eDsElementType_SubSlab, eDsElementType_SectionOnSlab, eDsElementType_Boundary, eDsElementType_Storey_RN, eDsElementType_PointSupportPoint, eDsElementType_PointSupportLine, eDsElementType_LineSupportLine, eDsElementType_LineSupportSurface, eDsElementType_Connection, eDsElementType_IntegrationStrip, eDsElementType_Independent, eDsElementType_IntegrationMember More... | |
eResLocation | Location [get, set] |
This enum defines the position for which the 2D results will be binded, like centres of mesh elements or in nodes with different options for averaging More... | |
byte | Magnitude [get, set] |
Property representing the magnitude index. See the following list of FEM-related ResultTypes and their magnitudes: FemBeamDeformations: Ux, Uy, Uz, Fix, Fiy, Fiz, Uglob, eMagnitude_Count FemBeamRelativeDeformations: Uy, Rel_Uy, Uz, Rel_Uz, eMagnitude_Count FemBeamInnerForces: N = 0, Vy, Vz, Mx, My, Mz, Vr, eMagnitude_Count FemBeamContactForces: Rx, Ry, Rz, Mrx, Mry, Mrz, eMagnitude_Count FemSlabDeformations: Ux, Uy, Uz, Fix, Fiy, Fiz, Uglob, eMagnitude_Count FemSlabInnerForces_Extended: mx, my, mxy, qx, qy, nx, ny, qxy, m1, m2, alphab, mtmaxb, qmaxb, etab, n1, n2, alpham, qmaxm, mxD_plus, myD_plus, mcD_plus, mxD_minus, myD_minus, mcD_minus, nxD, nyD, ncD, eMagnitude_Count FemSlabInnerForces: mx = 0, my, mxy, qx, qy, nx, ny, qxy, eMagnitude_Count FemSlabInnerForces_Principal: m1 = 0, m2, alphab, mtmaxb, qmaxb, betab, n1, n2, alpham, qmaxm, eMagnitude_Count FemSlabInnerForces_Design: mxD_plus, myD_plus, mcD_plus, mxD_minus, myD_minus, mcD_minus, nxD, nyD, ncD, eMagnitude_Count FemSlabStress: sigx_plus, sigy_plus, sigxy_plus, sigx_minus, sigy_minus, sigxy_minus, sig1_plus, sig2_plus, alpha_plus, sigE_plus, sig1_minus, sig2_minus, alpha_minus, sigE_minus, taumax, sigZ, sigxb, sigyb, sigxyb, sigxm, sigym, sigxym, sigEm1, taux, tauy, sigEmax, sigEm2, sigT_plus, sigT_minus, sigTmax, sigTm, sigR_plus, sigR_minus, sigRmax, sigRm, sigB_plus, sigB_minus, sigBmax, sigBm, sigm1, sigm2, alpham, eMagnitude_Count FemSlabContactStress: tauzx, tauyz, sigz, eMagnitude_Count FemResultingForces: Fx, Fy, Fz, Mx, My, Mz, eMagnitude_Count FemNodeReactions: Rx, Ry, Rz, Mrx, Mry, Mrz, eMagnitude_Count FemLineReactionsIntesities: Rx, Ry, Rz, Mrx, Mry, Mrz, rx, ry, rz, mrx, mry, mrz, eMagnitude_Count FemNodalMasses: Mx, My, Mz, Fix, Fiy, Fiz, eMagnitude_Count FemStrain: eBasic0, eBasic1, eBasic2, eBasic3, eBasic4, eBasic5, eBasic6, eBasic7, eEps_x_p, eEps_y_p, eGamma_xy_p, eEps_x_m, eEps_y_m, eGamma_xy_m, eEps_1_p, eEps_2_p, eAlpha_p, eEps_1_m, eEps_2_m, eAlpha_m, eEps_max_p, eEps_min_p, eEps_max_m, eEps_min_m, eEps_max, eEps_min, eEps_M_p, eEps_M_m, eEps_M, eMagnitude_Count FemPlasticStrain: FemSubsoilOfMacros2D: C1z, C2x, C2y, C1x, C1y, eMagnitude_Count FemOtherDataForSoilin: X, Y, w, eMagnitude_Count FemModalFactors: Wx, Wy, Wz, WxR, WyR, WzR, DampRatio, eMagnitude_Count FemSlabIsotropicProperties: E = 0, mi, h, DRel, eMagnitude_Count FemNodeDeformations: Ux, Uy, Uz, Fix, Fiy, Fiz, Uglob, eMagnitude_Count More... | |
ApiGuid | ResultTypeID [get, set] |
Property representing the result type unique identifier More... | |
eResultType | ResultType [get, set] |
Enum for definition type of result: eNone = 0, FEMBase results 2D: eFemDeformations = 1, eFemInnerForces = 2, eFemStress = 3, eFemContactStress = 4, eFemRatedQuantitesForReinforcement = 5, eFemReinforcement = 6, eFemPowerLoadOfMacros2D = 7, eFemTemperatureLoadOfMacros2D = 8, eFemSubsoilOfMacros2D = 9, eFemParametersOfIsotopyOnMacros2D = 10, eFemSubsoilForSoilin = 11, eFemOtherDataForSoilin = 12, eFemCracks = 13, eFemStrains = 14, eFemPlasticStrains = 15, eFemInnerForces_Extended = 16, eReactionsNodes = 17, FEMBase results 1D: eFemBeamDeformation = 30, eFemBeamInnerForces = 31, eFemBeamContactForces = 32,// FemBase results per storeys:eStoreyData, eStoreyDisplacements, eStoreyAccelerations, eStoreyForces, eStoreyAccidentalTorsion, eInterStoreyDrift, eReservedForRelease2013_1, Recalculated FEMBase results: eFemBeamRelativeDeformation = 50, eFemResultingForces, user-defined results: eTestCheck = 101, eTimberCheckSLS, eTimberCheckULS, eDFDesignAsLongitudinal, eDFCheckResponse, eDFInternalForces, eDFDesignShearNBR, eDFUserTemplate, e2DConcreteBrazil, e1DConcreteECEN, eCombinatorSlabStrain, eCombinatorBeamStrain, eMemberStress_Sigma, eFibrePosition, eFibreDeformation, eAdaptiveMesh, eELFLoads, eEN_1993_SteelULS, eEN_1993_SteelFire, eIDEA_StatiCa_Connection, eEN_1993_SteelSLS, eSIA_263_SteelULS, eSteel_SLS, eEN_1999_AluminiumULS, eLastResultType More... | |
eRibRecalculationType | RibRecalculationType [get, set] |
Enum for definition of recalculation type for ribs More... | |
eCoordSystem | CoordSystem [get, set] |
Enum for definition of result coordinate system: eCoordSys_Local = 0, // - reactions in the nodes will be returned in rotated coordinate system // - reactions on lines will be returned in the local coordinate system of the line // - deformations,internal forces and contact stresses on the 1D elements will be returned in the principal coordinate system of the 1D element // - deformations and internal forces on the 2D elements will be returned in the local coordinate system of the 2D macroelement. eCoordSys_Global = 1, // - reactions in the nodes will be returned in global coordinate system // - reactions on lines will be returned in the global coordinate system // - deformations and contact stresses on the beams will be returned in the global coordinate system // - inner forces on the beams will be returned in the coordinate system of the cross section // - deformations on the 2D elements will be returned in the global coordinate system eCoordSys_User = 2, // - deformations, ihned forces and contact stresses on the beams will be returned in the user coordinate system of the beam eCoordSys_Principal = 3, // - used only for storey results! eCoordSys_ByMember = 4 More... | |
eDsElementType | CaseType [get, set] |
This enum defines the type of loading case for which results will be obtained: eDsElementType_LoadCase, eDsElementType_Combination, eDsElementType_CombiKey eDsElementType_NonlinearCombination, eDsElementType_Class, eDsElementType_MassCombination, eDsElementType_Stability More... | |
ApiGuid | CaseId [get, set] |
This guid defines the loading case for which results will be obtained More... | |
This class is used for definition of result you want to get.
SCIA.OpenAPI.Results.ResultKey.ResultKey | ( | ) |
Constructor for definition of new result key
string SCIA.OpenAPI.Results.ResultKey.TextOutput | ( | ) |
Method that provide text output of result key. It can be used to print the text representation of key into command line.
|
getset |
This guid defines the loading case for which results will be obtained
|
getset |
This enum defines the type of loading case for which results will be obtained: eDsElementType_LoadCase, eDsElementType_Combination, eDsElementType_CombiKey eDsElementType_NonlinearCombination, eDsElementType_Class, eDsElementType_MassCombination, eDsElementType_Stability
|
getset |
Enum for definition of result coordinate system: eCoordSys_Local = 0, // - reactions in the nodes will be returned in rotated coordinate system // - reactions on lines will be returned in the local coordinate system of the line // - deformations,internal forces and contact stresses on the 1D elements will be returned in the principal coordinate system of the 1D element // - deformations and internal forces on the 2D elements will be returned in the local coordinate system of the 2D macroelement.
eCoordSys_Global = 1, // - reactions in the nodes will be returned in global coordinate system // - reactions on lines will be returned in the global coordinate system // - deformations and contact stresses on the beams will be returned in the global coordinate system // - inner forces on the beams will be returned in the coordinate system of the cross section // - deformations on the 2D elements will be returned in the global coordinate system
eCoordSys_User = 2, // - deformations, ihned forces and contact stresses on the beams will be returned in the user coordinate system of the beam
eCoordSys_Principal = 3, // - used only for storey results!
eCoordSys_ByMember = 4
|
getset |
This enum defines the dimension of obtained results:
eDim_undefined = -1,
eDim_1D = 1, //FB_1D //results on beams
eDim_2D = 2, //FB_2D //2D macros
eDim_3D = 3, //FB_3D //3D macros
eDim_reactionsPoint = 4, //FB_REA_PT, // reactions in points
eDim_reactionsLine = 5, //FB_REA_LIN, // reactions on lines
eDim_2DSection = 6, //Results on 2d sections
eDim_1DSection = 7, //Results on 1d sections
eDim_Storey = 8 //Results per storeys
|
getset |
Name of the entity/member (SEn name) for which you want to get results
|
getset |
This enum defines the type of entity for which you results will be obtained: eDsElementType_None, eDsElementType_Beam, eDsElementType_Slab, eDsElementType_Storey, eDsElementType_Node, eDsElementType_SubSlab, eDsElementType_SectionOnSlab, eDsElementType_Boundary, eDsElementType_Storey_RN, eDsElementType_PointSupportPoint, eDsElementType_PointSupportLine, eDsElementType_LineSupportLine, eDsElementType_LineSupportSurface, eDsElementType_Connection, eDsElementType_IntegrationStrip, eDsElementType_Independent, eDsElementType_IntegrationMember
|
getset |
This enum defines the position for which the 2D results will be binded, like centres of mesh elements or in nodes with different options for averaging
|
getset |
Property representing the magnitude index. See the following list of FEM-related ResultTypes and their magnitudes:
FemBeamDeformations: Ux, Uy, Uz, Fix, Fiy, Fiz, Uglob, eMagnitude_Count
FemBeamRelativeDeformations: Uy, Rel_Uy, Uz, Rel_Uz, eMagnitude_Count
FemBeamInnerForces: N = 0, Vy, Vz, Mx, My, Mz, Vr, eMagnitude_Count
FemBeamContactForces: Rx, Ry, Rz, Mrx, Mry, Mrz, eMagnitude_Count
FemSlabDeformations: Ux, Uy, Uz, Fix, Fiy, Fiz, Uglob, eMagnitude_Count
FemSlabInnerForces_Extended: mx, my, mxy, qx, qy, nx, ny, qxy, m1, m2, alphab, mtmaxb, qmaxb, etab, n1, n2, alpham, qmaxm, mxD_plus, myD_plus, mcD_plus, mxD_minus, myD_minus, mcD_minus, nxD, nyD, ncD, eMagnitude_Count
FemSlabInnerForces: mx = 0, my, mxy, qx, qy, nx, ny, qxy, eMagnitude_Count
FemSlabInnerForces_Principal: m1 = 0, m2, alphab, mtmaxb, qmaxb, betab, n1, n2, alpham, qmaxm, eMagnitude_Count
FemSlabInnerForces_Design: mxD_plus, myD_plus, mcD_plus, mxD_minus, myD_minus, mcD_minus, nxD, nyD, ncD, eMagnitude_Count
FemSlabStress: sigx_plus, sigy_plus, sigxy_plus, sigx_minus, sigy_minus, sigxy_minus, sig1_plus, sig2_plus, alpha_plus, sigE_plus, sig1_minus, sig2_minus, alpha_minus, sigE_minus, taumax, sigZ, sigxb, sigyb, sigxyb, sigxm, sigym, sigxym, sigEm1, taux, tauy, sigEmax, sigEm2, sigT_plus, sigT_minus, sigTmax, sigTm, sigR_plus, sigR_minus, sigRmax, sigRm, sigB_plus, sigB_minus, sigBmax, sigBm, sigm1, sigm2, alpham, eMagnitude_Count
FemSlabContactStress: tauzx, tauyz, sigz, eMagnitude_Count
FemResultingForces: Fx, Fy, Fz, Mx, My, Mz, eMagnitude_Count
FemNodeReactions: Rx, Ry, Rz, Mrx, Mry, Mrz, eMagnitude_Count
FemLineReactionsIntesities: Rx, Ry, Rz, Mrx, Mry, Mrz, rx, ry, rz, mrx, mry, mrz, eMagnitude_Count
FemNodalMasses: Mx, My, Mz, Fix, Fiy, Fiz, eMagnitude_Count
FemStrain: eBasic0, eBasic1, eBasic2, eBasic3, eBasic4, eBasic5, eBasic6, eBasic7, eEps_x_p, eEps_y_p, eGamma_xy_p, eEps_x_m, eEps_y_m, eGamma_xy_m, eEps_1_p, eEps_2_p, eAlpha_p, eEps_1_m, eEps_2_m, eAlpha_m, eEps_max_p, eEps_min_p, eEps_max_m, eEps_min_m, eEps_max, eEps_min, eEps_M_p, eEps_M_m, eEps_M, eMagnitude_Count
FemPlasticStrain:
FemSubsoilOfMacros2D: C1z, C2x, C2y, C1x, C1y, eMagnitude_Count
FemOtherDataForSoilin: X, Y, w, eMagnitude_Count
FemModalFactors: Wx, Wy, Wz, WxR, WyR, WzR, DampRatio, eMagnitude_Count
FemSlabIsotropicProperties: E = 0, mi, h, DRel, eMagnitude_Count
FemNodeDeformations: Ux, Uy, Uz, Fix, Fiy, Fiz, Uglob, eMagnitude_Count
|
getset |
Enum for definition type of result:
eNone = 0,
FEMBase results 2D: eFemDeformations = 1, eFemInnerForces = 2, eFemStress = 3, eFemContactStress = 4, eFemRatedQuantitesForReinforcement = 5, eFemReinforcement = 6, eFemPowerLoadOfMacros2D = 7, eFemTemperatureLoadOfMacros2D = 8, eFemSubsoilOfMacros2D = 9, eFemParametersOfIsotopyOnMacros2D = 10, eFemSubsoilForSoilin = 11, eFemOtherDataForSoilin = 12, eFemCracks = 13, eFemStrains = 14, eFemPlasticStrains = 15, eFemInnerForces_Extended = 16, eReactionsNodes = 17,
FEMBase results 1D: eFemBeamDeformation = 30, eFemBeamInnerForces = 31, eFemBeamContactForces = 32,// FemBase results per storeys:eStoreyData, eStoreyDisplacements, eStoreyAccelerations, eStoreyForces, eStoreyAccidentalTorsion, eInterStoreyDrift, eReservedForRelease2013_1,
Recalculated FEMBase results: eFemBeamRelativeDeformation = 50, eFemResultingForces,
user-defined results: eTestCheck = 101, eTimberCheckSLS, eTimberCheckULS, eDFDesignAsLongitudinal, eDFCheckResponse, eDFInternalForces, eDFDesignShearNBR, eDFUserTemplate, e2DConcreteBrazil, e1DConcreteECEN, eCombinatorSlabStrain, eCombinatorBeamStrain, eMemberStress_Sigma, eFibrePosition, eFibreDeformation, eAdaptiveMesh, eELFLoads, eEN_1993_SteelULS, eEN_1993_SteelFire, eIDEA_StatiCa_Connection, eEN_1993_SteelSLS, eSIA_263_SteelULS, eSteel_SLS, eEN_1999_AluminiumULS, eLastResultType
|
getset |
Property representing the result type unique identifier
|
getset |
Enum for definition of recalculation type for ribs