SCIA Engineer OpenAPI  19.1.3030
SCIA.OpenAPI.Structure Class Reference

Provides methods for work with the Scia Engineer model - definition of new entities, synchronization of model with Scia Engineer model, etc. Class is initialized in EsaProject.EsaProject(object, Guid). More...

Public Member Functions

void RefreshModel_ToSCIAEngineer ()
 Send the content of the Structure to the data server of the Scia Engineer EsaProject instance More...
 
void RefreshModel_FromSCIAEngineer ()
 Load the content of the Scia Engineer EsaProject instance data server into the Structure More...
 
bool CreateMaterial (Material material)
 Create new material in the Structure More...
 
bool CreateCrossSection (CrossSectionManufactured Css)
 Create new cross-section in the Structure from CrossSectionManufactured More...
 
bool CreateCrossSection (CrossSectionParametric Css)
 Create new cross-section in the Structure from CrossSectionParametric More...
 
bool CreateNode (StructNode Node)
 Create new structural node in the Structure More...
 
bool CreateBeam (Beam Beam)
 Create new beam node in the Structure More...
 
bool CreateSlab (Slab slab)
 Create new slab in the Structure More...
 
bool CreatePointSupport (PointSupport Support)
 Create new support in node in the Structure More...
 
bool CreateLineSupport (LineSupport Support)
 Create new line support in the Structure More...
 
bool CreateLoadGroup (LoadGroup Group)
 Create new load group in the Structure More...
 
bool CreateLoadCase (LoadCase LC)
 Create new load case in the Structure More...
 
bool CreateCombination (Combination combination)
 Create new combination in the Structure More...
 
bool CreatePointLoadInNode (PointLoadInNode PointLoad)
 Create new point load in node in the Structure More...
 
bool CreatePointLoadFree (PointLoadFree PointLoadFree)
 Create new free force in point in Structure More...
 
bool CreateSurfaceLoad (SurfaceLoad SurfaceLoad)
 Create new surface load defined on slab in the Structure More...
 
bool CreateLineLoad (LineLoadOnBeam lineLoad)
 Create new line load defined on beam in the Structure. More...
 
bool CreateLineLoad (LineLoadOnSlabEdge lineLoad)
 Create new line load defined on slab edge in the Structure. More...
 
ResultOfPartialAddToAnalysisModel CreateAdmObject (params IAnalysisObject[] items)
 Method for direct addition of an ADM structural object into local ADM instance. To use this method, you must be able to create ADM objects in your application - example will be available at github.com/scia-garage More...
 
int FindBeamDsId (string Name)
 Method for getting the Scia Engineer ID of a Beam from its name. Method can be called after InitializeResultsAPI method is called, when dictionary is initialized. More...
 
int FindSlabDsId (string Name)
 Method for getting the Scia Engineer ID of a Slab from its name. Method can be called after InitializeResultsAPI method is called, when dictionary is initialized. More...
 
int FindNodeDsId (string Name)
 Method for getting the Scia Engineer ID of a StructNode from its name. Method can be called after InitializeResultsAPI method is called, when dictionary is initialized. More...
 
int FindLoadCaseDsId (ApiGuid Id)
 Method for getting the Scia Engineer ID of a LoadCase from its unique identifier (guid) More...
 
int FindCombinationDsId (ApiGuid Id)
 Method for getting the Scia Engineer ID of a Combination from its unique identifier (guid) More...
 
int FindClassDsId (ApiGuid Id)
 Method for getting the Scia Engineer ID of a class from its unique identifier (guid). More...
 
ResultsAPI InitializeResultsAPI ()
 Method for initialization of ResultsAPI More...
 
ApiGuid FindMaterialGuid (string name)
 Method for getting the guid of material's name. Material must be already referenced in the model. More...
 

Detailed Description

Provides methods for work with the Scia Engineer model - definition of new entities, synchronization of model with Scia Engineer model, etc. Class is initialized in EsaProject.EsaProject(object, Guid).

Member Function Documentation

◆ CreateAdmObject()

ResultOfPartialAddToAnalysisModel SCIA.OpenAPI.Structure.CreateAdmObject ( params IAnalysisObject []  items)

Method for direct addition of an ADM structural object into local ADM instance. To use this method, you must be able to create ADM objects in your application - example will be available at github.com/scia-garage

Parameters
itemsArray of items (or items separated by comma) to be added into ADM. Particular items should be of the same type OR must be independent on each other (i.e. no references between them).
Returns

◆ CreateBeam()

bool SCIA.OpenAPI.Structure.CreateBeam ( Beam  Beam)

Create new beam node in the Structure

Parameters
Beamprovide any Beam
Returns
true if operation succeeded, false if failed

◆ CreateCombination()

bool SCIA.OpenAPI.Structure.CreateCombination ( Combination  combination)

Create new combination in the Structure

Parameters
combinationprovide any Combination
Returns
true if operation succeeded, false if failed

◆ CreateCrossSection() [1/2]

bool SCIA.OpenAPI.Structure.CreateCrossSection ( CrossSectionManufactured  Css)

Create new cross-section in the Structure from CrossSectionManufactured

Parameters
Cssprovide any CrossSectionManufactured
Returns
true if operation succeeded, false if failed

◆ CreateCrossSection() [2/2]

bool SCIA.OpenAPI.Structure.CreateCrossSection ( CrossSectionParametric  Css)

Create new cross-section in the Structure from CrossSectionParametric

Parameters
Cssprovide any CrossSectionParametric
Returns
true if operation succeeded, false if failed

◆ CreateLineLoad() [1/2]

bool SCIA.OpenAPI.Structure.CreateLineLoad ( LineLoadOnBeam  lineLoad)

Create new line load defined on beam in the Structure.

Parameters
lineLoadprovide any LineLoadOnBeam
Returns
true if operation succeeded, false if failed

◆ CreateLineLoad() [2/2]

bool SCIA.OpenAPI.Structure.CreateLineLoad ( LineLoadOnSlabEdge  lineLoad)

Create new line load defined on slab edge in the Structure.

Parameters
lineLoadprovide any LineLoadOnSlabEdge
Returns
true if operation succeeded, false if failed

◆ CreateLineSupport()

bool SCIA.OpenAPI.Structure.CreateLineSupport ( LineSupport  Support)

Create new line support in the Structure

Parameters
Supportprovide any LineSupport
Returns
true if operation succeeded, false if failed

◆ CreateLoadCase()

bool SCIA.OpenAPI.Structure.CreateLoadCase ( LoadCase  LC)

Create new load case in the Structure

Parameters
LCprovide any LoadCase
Returns
true if operation succeeded, false if failed

◆ CreateLoadGroup()

bool SCIA.OpenAPI.Structure.CreateLoadGroup ( LoadGroup  Group)

Create new load group in the Structure

Parameters
Groupprovide any LoadGroup
Returns
true if operation succeeded, false if failed

◆ CreateMaterial()

bool SCIA.OpenAPI.Structure.CreateMaterial ( Material  material)

Create new material in the Structure

Parameters
materialprovide any Material
Returns
true if operation succeeded, false if failed

◆ CreateNode()

bool SCIA.OpenAPI.Structure.CreateNode ( StructNode  Node)

Create new structural node in the Structure

Parameters
Nodeprovide any StructNode
Returns
true if operation succeeded, false if failed

◆ CreatePointLoadFree()

bool SCIA.OpenAPI.Structure.CreatePointLoadFree ( PointLoadFree  PointLoadFree)

Create new free force in point in Structure

Parameters
PointLoadFreeprovide any PointLoadFree
Returns
true if operation succeeded, false if failed

◆ CreatePointLoadInNode()

bool SCIA.OpenAPI.Structure.CreatePointLoadInNode ( PointLoadInNode  PointLoad)

Create new point load in node in the Structure

Parameters
PointLoadprovide any PointLoadInNode
Returns
true if operation succeeded, false if failed

◆ CreatePointSupport()

bool SCIA.OpenAPI.Structure.CreatePointSupport ( PointSupport  Support)

Create new support in node in the Structure

Parameters
Supportprovide any PointSupport
Returns
true if operation succeeded, false if failed

◆ CreateSlab()

bool SCIA.OpenAPI.Structure.CreateSlab ( Slab  slab)

Create new slab in the Structure

Parameters
slabprovide any Slab
Returns
true if operation succeeded, false if failed

◆ CreateSurfaceLoad()

bool SCIA.OpenAPI.Structure.CreateSurfaceLoad ( SurfaceLoad  SurfaceLoad)

Create new surface load defined on slab in the Structure

Parameters
SurfaceLoadprovide any SurfaceLoad
Returns
true if operation succeeded, false if failed

◆ FindBeamDsId()

int SCIA.OpenAPI.Structure.FindBeamDsId ( string  Name)

Method for getting the Scia Engineer ID of a Beam from its name. Method can be called after InitializeResultsAPI method is called, when dictionary is initialized.

Parameters
Nameprovide the string with beam name as input
Returns
int with Scia Engineer ID

◆ FindClassDsId()

int SCIA.OpenAPI.Structure.FindClassDsId ( ApiGuid  Id)

Method for getting the Scia Engineer ID of a class from its unique identifier (guid).

Parameters
Idprovide guid of the class
Returns
int with the Scia Engineer ID

◆ FindCombinationDsId()

int SCIA.OpenAPI.Structure.FindCombinationDsId ( ApiGuid  Id)

Method for getting the Scia Engineer ID of a Combination from its unique identifier (guid)

Parameters
Idprovide guid of Combination
Returns
int with the Scia Engineer ID

◆ FindLoadCaseDsId()

int SCIA.OpenAPI.Structure.FindLoadCaseDsId ( ApiGuid  Id)

Method for getting the Scia Engineer ID of a LoadCase from its unique identifier (guid)

Parameters
Idprovide guid of LoadCase
Returns
int with the Scia Engineer ID

◆ FindMaterialGuid()

ApiGuid SCIA.OpenAPI.Structure.FindMaterialGuid ( string  name)

Method for getting the guid of material's name. Material must be already referenced in the model.

Parameters
nameprovide string with material name
Returns
guid of material
Exceptions
System.ArgumentExceptionThrown when the Analysis Object doesn't exist in the model.

◆ FindNodeDsId()

int SCIA.OpenAPI.Structure.FindNodeDsId ( string  Name)

Method for getting the Scia Engineer ID of a StructNode from its name. Method can be called after InitializeResultsAPI method is called, when dictionary is initialized.

Parameters
Nameprovide the string with beam name as input
Returns
int with Scia Engineer ID

◆ FindSlabDsId()

int SCIA.OpenAPI.Structure.FindSlabDsId ( string  Name)

Method for getting the Scia Engineer ID of a Slab from its name. Method can be called after InitializeResultsAPI method is called, when dictionary is initialized.

Parameters
Nameprovide the string with beam name as input
Returns
int with Scia Engineer ID

◆ InitializeResultsAPI()

ResultsAPI SCIA.OpenAPI.Structure.InitializeResultsAPI ( )

Method for initialization of ResultsAPI

Returns
initialized ResultsAPI object

◆ RefreshModel_FromSCIAEngineer()

void SCIA.OpenAPI.Structure.RefreshModel_FromSCIAEngineer ( )

Load the content of the Scia Engineer EsaProject instance data server into the Structure

◆ RefreshModel_ToSCIAEngineer()

void SCIA.OpenAPI.Structure.RefreshModel_ToSCIAEngineer ( )

Send the content of the Structure to the data server of the Scia Engineer EsaProject instance


The documentation for this class was generated from the following file: