SCIA Engineer OpenAPI  24.0.3015
SCIA.OpenAPI.Environment Class Reference

Treats the Scia Engineer environment - starts Scia Engineer, creates EsaProject, creates Structure, treats the communication between your application and Scia Engineer More...

Inheritance diagram for SCIA.OpenAPI.Environment:

Public Types

enum  TypeOfExtProject {
  TypeOfExtProject.TypeXML, TypeOfExtProject.TypeESA, TypeOfExtProject.TypeRevit, TypeOfExtProject.TypeTekla,
  TypeOfExtProject.TypeIFC, TypeOfExtProject.TypeAEF
}
 Enum defining the type of external project More...
 
enum  GuiMode {
  GuiMode.ShowWindowHide = TEnvESAApp_ShowWindow.eEPShowWindowHide, GuiMode.ShowWindowShow = TEnvESAApp_ShowWindow.eEPShowWindowShow, GuiMode.ShowWindowShowNA = TEnvESAApp_ShowWindow.eEPShowWindowShowNA, GuiMode.ShowWindowShowNormal = TEnvESAApp_ShowWindow.eEPShowWindowShowNormal,
  GuiMode.ShowWindowShowMinimized = TEnvESAApp_ShowWindow.eEPShowWindowShowMinimized, GuiMode.ShowWindowShowMinNoActive = TEnvESAApp_ShowWindow.eEPShowWindowShowMinNoActive
}
 Enum for definition of visibility of GUI More...
 

Public Member Functions

 Environment (string sciaEngineerSystemPath, string appTempPath, string ReqAPIversion)
 Constructor for initialization of new Environment. This is the starting point for external applications. More...
 
 Environment ()
 A parameter-less constructor, that should be used in COM-based calls. It should be followed by the Init(string, string, string) method. More...
 
void Dispose ()
 Method for disposing the Environment object. This method MUST be called when you finish your program to free-up resources. More...
 
bool Init (string sciaEngineerSystemPath, string appTempPath, string ReqAPIversion)
 A method for initialization of empty object, that is crated by the Environment.Environment() parameters-less constructor. This method should be called after using the parameter-less constructor. More...
 
bool RunSCIAEngineer (GuiMode guimode)
 Method for running the Scia Engineer instance with options of GUI visibility More...
 
EsaProject OpenProject (string path)
 Method for opening Scia Engineer projects More...
 
void CloseAllProjects (SaveMode savemode)
 Method for closing all projects with options for saving More...
 
bool CloseActiveProject (SaveMode savemode)
 Method for closing the currently active project (which is active in Scia Engineer now) More...
 
EsaProject CreateProject (Guid projectTypeID, out ApiGuid newProjectID)
 Method for creating new project from scratch. Dialogue for selection of material, functionalities, etc. is displayed. More...
 
EsaProject ImportProjectFromFile (TypeOfExtProject importType, string projectPath, out ApiGuid newProjectID)
 Method for importing external file as new Scia Engineer project. More...
 
void UpdateProject (TypeOfExtProject updateType, string updateFilePath, ApiGuid projectIDToUpdate)
 This method update the currenlty opened project (defined by guid) by some external file. More...
 

Public Attributes

ErrorRepository ErrorRepository => ServiceWrapper.ErrorRepository
 Log errors information More...
 

Properties

string AppTempPath [get]
 OpenAPI temp path More...
 

Detailed Description

Treats the Scia Engineer environment - starts Scia Engineer, creates EsaProject, creates Structure, treats the communication between your application and Scia Engineer

Member Enumeration Documentation

◆ GuiMode

Enum for definition of visibility of GUI

Enumerator
ShowWindowHide 

start with hidden gui OR hide gui

ShowWindowShow 

start with visible gui OR show gui

ShowWindowShowNA 

start with visible gui, but the window is not active OR show gui without making active

ShowWindowShowNormal 

start with visible gui OR show gui, this one should be used when executing new SCIA Engineer instance with visible gui

ShowWindowShowMinimized 

start with visible gui, window minimized

ShowWindowShowMinNoActive 

start with visible gui, window minimized and not active

◆ TypeOfExtProject

Enum defining the type of external project

Enumerator
TypeXML 

Project defined within XML file

TypeESA 

Scia Engineer project

TypeRevit 

Autodesk Revit project

TypeTekla 

Tekla project

TypeIFC 

Project defined within IFC file

TypeAEF 

Project defined using Analytical Exchange Format saved .xlsx. See http://dev.aef.guide/Default.htm

Constructor & Destructor Documentation

◆ Environment() [1/2]

SCIA.OpenAPI.Environment.Environment ( string  sciaEngineerSystemPath,
string  appTempPath,
string  ReqAPIversion 
)

Constructor for initialization of new Environment. This is the starting point for external applications.

Parameters
sciaEngineerSystemPathprovide string with path to Scia Engineer install directory
appTempPathprovide string with path to desired temp location, it can be relative e.g. ".\temp"</param> <param name="ReqAPIversion">Provide string with version of Scia Engineer you are going to use. This version can be found in Scia Engineer application in Help>About

◆ Environment() [2/2]

SCIA.OpenAPI.Environment.Environment ( )

A parameter-less constructor, that should be used in COM-based calls. It should be followed by the Init(string, string, string) method.

Member Function Documentation

◆ CloseActiveProject()

bool SCIA.OpenAPI.Environment.CloseActiveProject ( SaveMode  savemode)

Method for closing the currently active project (which is active in Scia Engineer now)

Parameters
savemodeprovide the SaveMode to define the project saving mode during close

◆ CloseAllProjects()

void SCIA.OpenAPI.Environment.CloseAllProjects ( SaveMode  savemode)

Method for closing all projects with options for saving

Parameters
savemodeprovide the SaveMode to define the project saving mode during close

◆ CreateProject()

EsaProject SCIA.OpenAPI.Environment.CreateProject ( Guid  projectTypeID,
out ApiGuid  newProjectID 
)

Method for creating new project from scratch. Dialogue for selection of material, functionalities, etc. is displayed.

Parameters
projectTypeID8844F383-848C-11D4-9F7C-00104BC3B443 for ESA project
newProjectIDparameter reference passed where the id of created project will be stored
Returns
Instance of the EsaProject

◆ Dispose()

void SCIA.OpenAPI.Environment.Dispose ( )

Method for disposing the Environment object. This method MUST be called when you finish your program to free-up resources.

◆ ImportProjectFromFile()

EsaProject SCIA.OpenAPI.Environment.ImportProjectFromFile ( TypeOfExtProject  importType,
string  projectPath,
out ApiGuid  newProjectID 
)

Method for importing external file as new Scia Engineer project.

Parameters
importTypetype of project being imported, see Environment.TypeOfExtProject for details
projectPathstring containing path to external file
newProjectIDvariable where the guid of new EsaProject instance is written
Returns
Instance of the EsaProject

◆ Init()

bool SCIA.OpenAPI.Environment.Init ( string  sciaEngineerSystemPath,
string  appTempPath,
string  ReqAPIversion 
)

A method for initialization of empty object, that is crated by the Environment.Environment() parameters-less constructor. This method should be called after using the parameter-less constructor.

Parameters
sciaEngineerSystemPathprovide string with path to Scia Engineer install directory
appTempPathprovide string with path to desired temp location, it can be relative e.g. ".\temp"</param> <param name="ReqAPIversion">Provide string with version of Scia Engineer you are going to use. This version can be found in Scia Engineer application in Help>About

◆ OpenProject()

EsaProject SCIA.OpenAPI.Environment.OpenProject ( string  path)

Method for opening Scia Engineer projects

Parameters
pathString containing path to the .esa project file
Returns
Returns the EsaProject instance

◆ RunSCIAEngineer()

bool SCIA.OpenAPI.Environment.RunSCIAEngineer ( GuiMode  guimode)

Method for running the Scia Engineer instance with options of GUI visibility

Parameters
guimodeprovide the GuiMode to define the mode of gui visibility
Returns
Bool saying whether Scia Engineer started successfully

◆ UpdateProject()

void SCIA.OpenAPI.Environment.UpdateProject ( TypeOfExtProject  updateType,
string  updateFilePath,
ApiGuid  projectIDToUpdate 
)

This method update the currenlty opened project (defined by guid) by some external file.

Parameters
updateTypeDefine the type of external project you want to use for update.
updateFilePathPath to external file that will be used for update.
projectIDToUpdateGUID of opened project that should be updated from external file.

Member Data Documentation

◆ ErrorRepository

ErrorRepository SCIA.OpenAPI.Environment.ErrorRepository => ServiceWrapper.ErrorRepository

Log errors information

Property Documentation

◆ AppTempPath

string SCIA.OpenAPI.Environment.AppTempPath
get

OpenAPI temp path


The documentation for this class was generated from the following file: