SCIA Engineer OpenAPI  24.0.3015
SCIA.OpenAPI Namespace Reference

Namespaces

namespace  Models
 
namespace  OpenAPIEnums
 
namespace  Results
 
namespace  ResultsCalculation
 
namespace  StructureModelDefinition
 
namespace  Utils
 

Classes

class  ApiGuid
 Class for treating unique identifiers for e.g. particular structural entities. More...
 
class  ApiGuidArr
 Class for treating unique identifiers array, e.g. for definnition of array of nodes for slab creation. More...
 
class  Environment
 Treats the Scia Engineer environment - starts Scia Engineer, creates EsaProject, creates Structure, treats the communication between your application and Scia Engineer More...
 
class  EsaProject
 Treats the Structure and provides functionality regarding the Project like closing project, running analysis, etc. More...
 
class  Structure
 Provides methods for work with the Scia Engineer model - definition of new entities, synchronization of model with Scia Engineer model, etc. Class is initialized in EsaProject. More...
 

Enumerations

enum  SaveMode { SaveMode.SaveChangesNo = TEnvESAApp_SaveChanges.eEPSaveChangesNo, SaveMode.SaveChangesPrompt = TEnvESAApp_SaveChanges.eEPSaveChangesPrompt, SaveMode.SaveChangesYes = TEnvESAApp_SaveChanges.eEPSaveChangesYes }
 Enum for definition saving project during closing More...
 

Enumeration Type Documentation

◆ SaveMode

enum SCIA.OpenAPI.SaveMode
strong

Enum for definition saving project during closing

Enumerator
SaveChangesNo 

do not save the project

SaveChangesPrompt 

display messagebox whether to save or not

SaveChangesYes 

save the project